playMaker

Author Topic: Unity 5.5 Particle Emission Rate  (Read 818 times)

MajorIdea

  • Full Member
  • ***
  • Posts: 111
    • View Profile
Unity 5.5 Particle Emission Rate
« on: December 01, 2016, 07:43:21 AM »
Hi! Hope I'm posting this in the right place.

Basically in the old particle system we could choose the type of emission rate and that would work neatly with Playmaker's Set Property.

But now we can choose to use both Rate over Time and Rate over Distance at the same time and Playmaker's Set Property fails to take this into consideration defaulting to the first option.

I was using Rate over Distance and now I don't have access to it anymore. I'm using a work-around with the enableEmission since the value is constant but I figured I'd post it here.

Thanks!


jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Re: Unity 5.5 Particle Emission Rate
« Reply #1 on: December 01, 2016, 11:33:56 PM »
Hi,

 Can you file a bug report on this, it needs to be address for sure. While 5.5 is in beta, you may encounter similar issues for sure, thanks for reporting! it's very helpfull.

The solution would be to make a custom action, that would solve the problem straight away. If you can't code custom actions, I'll do them, no problem, just let me know.

 Bye,

 Jean

hunz

  • Playmaker Newbie
  • *
  • Posts: 35
    • View Profile
Re: Unity 5.5 Particle Emission Rate
« Reply #2 on: July 06, 2017, 03:37:01 AM »
Hello.  Just seeing if this was every resolved?  I'm currently trying to animate the the rateovertime but can't get access to it.

Thanks you so much!