playMaker

Author Topic: Unity 5.6 Beta Patch  (Read 6724 times)

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3205
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Unity 5.6 Beta Patch
« Reply #30 on: April 01, 2017, 09:42:53 AM »
Quick update: We released Playmaker 1.8.4 for Unity 5.6 compatibility. Also the final 5.6 release fixed the 5.6 beta bug with missing scripts when updating projects.

Salja

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #31 on: April 01, 2017, 03:23:54 PM »
Thanks but i have 2 Errors after Import the new version

http://prntscr.com/erbnko

markmandarin

  • Playmaker Newbie
  • *
  • Posts: 26
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #32 on: April 02, 2017, 07:39:48 AM »
I have these warnings (Unity 5.6.0f3 / Playmaker 1.8.4).

Both have gone when I playing

Assets/PlayMaker/Actions/Editor/LookAtActionEditor.cs(70,25): warning CS0618: `UnityEditor.Handles.ConeCap(int, UnityEngine.Vector3, UnityEngine.Quaternion, float)' is obsolete: `Use ConeHandleCap instead'

Assets/PlayMaker/Actions/Editor/MoveTowardsActionEditor.cs(64,21): warning CS0618: `UnityEditor.Handles.ConeCap(int, UnityEngine.Vector3, UnityEngine.Quaternion, float)' is obsolete: `Use ConeHandleCap instead'

jbonastre

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #33 on: April 03, 2017, 01:07:40 AM »
After upgrading the plugin with Unity 5.6.0f3, I´m getting these errors:

Assets/PlayMaker/Actions/SceneManager/Editor/LoadSceneCustomEditor.cs(17,24): error CS0030: Cannot convert type `HutongGames.PlayMaker.FsmStateAction' to `LoadScene'

Assets/PlayMaker/Actions/SceneManager/Editor/LoadSceneCustomEditor.cs(21,15): error CS1061: Type `LoadScene' does not contain a definition for `sceneReference' and no extension method `sceneReference' of type `LoadScene' could be found. Are you missing an assembly reference?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #34 on: April 03, 2017, 01:37:27 AM »
Hi,

 yes, PlayMaker was updated on the 31st to comply with 5.6 and also the latest version of 5.6 fixed a problem on its own too, so know we should be good for a great 5.6 cycle and looking forward to the new Unity numbering convention :)

 Bye,

 Jean

DennisJensen

  • Junior Playmaker
  • **
  • Posts: 84
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #35 on: April 09, 2017, 04:54:07 AM »
After I updated today I get this error, not sure why.

PlayerSettings Validation: Requested build target group (27) doesn't exist; #define symbols for scripting won't be added.
UnityEditor.PlayerSettings:SetScriptingDefineSymbolsForGroup(BuildTargetGroup, String)
HutongGames.PlayMakerEditor.PlayMakerDefines:AddScriptingDefineSymbolToAllTargets(String) (at Assets/PlayMaker/Editor/PlayMakerDefines.cs:42)
HutongGames.PlayMakerEditor.PlayMakerDefines:.cctor() (at Assets/PlayMaker/Editor/PlayMakerDefines.cs:23)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()
Game Designer, CEO, Artist
http://2ndStudio.com

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #36 on: April 09, 2017, 10:44:26 PM »
Hi,

 this is likely because you need to install the latest version of PlayMaker, the patch is now featured in the official update from the Asset store.

 Bye,

 Jean

DennisJensen

  • Junior Playmaker
  • **
  • Posts: 84
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #37 on: April 10, 2017, 12:18:03 AM »
this is likely because you need to install the latest version of PlayMaker, the patch is now featured in the official update from the Asset store.


Thank you for the answer. I did update playmaker yesterday as well, took the latest version from the asset store.
Game Designer, CEO, Artist
http://2ndStudio.com

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #38 on: April 10, 2017, 01:04:21 AM »
Hi,

 ok, so what target are you publishing for?

 Bye,

 Jean

DennisJensen

  • Junior Playmaker
  • **
  • Posts: 84
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #39 on: April 10, 2017, 05:41:52 AM »
Windows
Game Designer, CEO, Artist
http://2ndStudio.com

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #40 on: April 10, 2017, 10:33:29 PM »
Hi,

That's odd. Can you try on a new fresh project and import just PlayMaker?

Bye,

 Jean

DennisJensen

  • Junior Playmaker
  • **
  • Posts: 84
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #41 on: April 11, 2017, 12:33:16 AM »
Sorry Jean, my mistake. I must have done something wrong while updating, I checked another project and reimported it in my project, now it works.
Game Designer, CEO, Artist
http://2ndStudio.com

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #42 on: April 11, 2017, 02:47:53 AM »
Hi,

 good, no worries, the two step update of PlayMaker is sometimes tricky to get right but a necessary evil unfortunatly.

 Bye,

 Jean

TristanKang

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #43 on: April 17, 2017, 08:01:36 AM »
Hi, I just recently installed Unity 5 and Playmaker (both latest version). However I keep getting these messages.

Assets/PlayMaker/Actions/Editor/LookAtActionEditor.cs(70,25): warning CS0618: `UnityEditor.Handles.ConeCap(int, UnityEngine.Vector3, UnityEngine.Quaternion, float)' is obsolete: `Use ConeHandleCap instead'

Assets/PlayMaker/Actions/Editor/MoveTowardsActionEditor.cs(64,21): warning CS0618: `UnityEditor.Handles.ConeCap(int, UnityEngine.Vector3, UnityEngine.Quaternion, float)' is obsolete: `Use ConeHandleCap instead'

Judging by previous posts, it seems people who updated experience this issue. But I freshly installed Unity and Playmaker and still get this message. Is there anyway to fix it? I tried to open visual studio and edit but the editor doesn't recognise ConeHandleCap.

Replacing ConeCap to ConeHandleCap seems not working. Is there some solution for it?

Best.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12342
  • Official Playmaker Support
    • View Profile
Re: Unity 5.6 Beta Patch
« Reply #44 on: April 17, 2017, 11:12:59 PM »
Hi,

Which version of 5.6 exactly? I don't get these.

And don't worry to much about obsolete warnings, they won't affect your game at all.

 Bye,

 Jean