playMaker

Author Topic: Unity Ads Problem with Mono2x[SOLVED]  (Read 765 times)

Tenchion

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Unity Ads Problem with Mono2x[SOLVED]
« on: February 09, 2017, 01:00:32 PM »
Hello,
I have a problem with using show ad action in my game.
The action works perfectly in PC editor the test screen is showing up. I have the problem with using it on my Android device
I'd like to ask you will the show ad action work in Mono2x scripting backend on Android? I'm asking because the game freezes every time when the show ad should happen. It works well on IL2CPP but then I have some big issues with Set Property action: it dosnt work at all with setting particle emission with it.

Please help :(
« Last Edit: February 15, 2017, 11:53:20 PM by jeanfabre »

Tenchion

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: Unity Ads Problem with Mono2x
« Reply #1 on: February 09, 2017, 02:09:05 PM »
OK it looks like backend doesn't matter here. It looks like the game has stopped on 'show ad' action, there is no freeze, just nothing happens ;x

Tenchion

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: Unity Ads Problem with Mono2x
« Reply #2 on: February 09, 2017, 02:36:05 PM »
ok it's getting strange ;x "unity ads is ready" action is showing that my adds service is not ready. I set everything on my unity ads account and it even worked some time ago.. how can I fix it?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Re: Unity Ads Problem with Mono2x
« Reply #3 on: February 10, 2017, 12:09:38 AM »
Hi,

 you need to use the LinkerWizard if you are using Actions such as SetProperty, because it uses reflections.

 Bye,

 Jean

Tenchion

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: Unity Ads Problem with Mono2x
« Reply #4 on: February 15, 2017, 12:29:38 PM »
Hello!
Thank you for Linker Wizard, it really helped me with fixing the set/get property actions.

However the ADs problem isn't fixed even on IL2CPP. I'm testing ADs on PC and the blue screen with the test AD is showing up. Nothing happens on Android. I even used the 'Ad is ready' action to check if the service is ready. Funny thing - ADs are NOT READY both on PC and Android :/

I use Unity 5.4 and it worked for a while some time ago (funny thing, TEST mode didn't work but after turning it off real ads showed up). I turned it off to edit other things and I didn't change anything connected with using ADs and they just stopped working after I turned it on again :/

Tenchion

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: Unity Ads Problem with Mono2x
« Reply #5 on: February 15, 2017, 10:57:17 PM »
OK I fixed it!
I added my device to test device list on unity ads dashboard and that's why it was not ready all the time :]

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Re: Unity Ads Problem with Mono2x
« Reply #6 on: February 15, 2017, 11:53:05 PM »
Hi,

 very good! I am glad your found the issue, it would have taken quite some time for me to figure this out :)

 Bye,

 Jean