playMaker

Author Topic: Importing Vector3LerpAdvanced action gives error[SOLVED]  (Read 264 times)

Nikolasio

  • Playmaker Newbie
  • *
  • Posts: 23
    • View Profile
Importing Vector3LerpAdvanced action gives error[SOLVED]
« on: April 03, 2017, 10:49:54 AM »
Hi,

I filed a bug report, but as I need the Vector3LerpAdvanced action to move forward maybe somebody has already experienced the same error message:

Assets/PlayMaker Custom Actions/__internal/PlayMakerActionsUtils.cs(1,0): error CS1525: Unexpected symbol `404'

Reimported the Vector3LerpAdvanced action via the ecosystem but the error message keeps appearing in the console.

Does somebody know what to do?

Cheers,
Nikola
 
« Last Edit: April 05, 2017, 02:12:31 AM by jeanfabre »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Hi,

 yes, this is a pain, the folder "__internal" is featured with a cap "__Internal" on some reps and Unity doesn't find the path properly,

 so you need to shake it a bit, rename "__internal" to "test", wait for Unity to recompile and then rename it "__Internal" with a cap I, it should work then when you download the action again..

 Sorry for the inconvenience... not sure how to fix this properly.

 Bye,

 Jean

Nikolasio

  • Playmaker Newbie
  • *
  • Posts: 23
    • View Profile
Hi Jean,

I did all that but still get the same error message.

Deleting the folder and then redownloading the Vector3LerpAdvanced action didn't solve it either.

Cheers,
Nikola

PS: when I use the ecosystem I also get this message:

Unsupported encoding: 'UTF-8,text/plain'
UnityEngine.WWW:get_text()
Net.FabreJean.PlayMaker.Ecosystem.EcosystemBrowser:OnInspectorUpdate() (at Assets/net.fabrejean/Editor/PlayMaker/Ecosystem/EcosystemBrowser.cs:2402)
UnityEditor.HostView:OnInspectorUpdate()

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Hi,

 Can you try to get it again now, I think it's going to work now, I simply did not update that action to match the cap I of __internal. d'oh...

 Bye,

 Jean

Nikolasio

  • Playmaker Newbie
  • *
  • Posts: 23
    • View Profile
Hi Jean,

Tried it a few times, I still get the error..

Cheers,
Nikola

Nikolasio

  • Playmaker Newbie
  • *
  • Posts: 23
    • View Profile
Hi Jean,

I updated the Vector3LerpAdvanced Action and the error message is solved.

Thx!:)

Grtz
Nikola