playMaker

Author Topic: PathFinding Addon Issue[SOLVED]  (Read 131 times)

bazzaro135

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
PathFinding Addon Issue[SOLVED]
« on: September 12, 2017, 05:47:55 AM »
I am very new to Unity as a whole and I am following a tutorial on youtube and all has been going well until he added the pathfinding addon via the ecosystem.

I am using Unity 5.5.0f3 and I am trying to add this https://hutonggames.fogbugz.com/default.asp?W1174

Once I add that addon I go to add an action to the FSM but none of the Nav options are there that the addon should have added.
I do have these errors in the console now tho,

Code: [Select]
Assets/PlayMaker PathFinding/Agent/GetAgentIsStopped.cs(71,31): error CS1061: Type `UnityEngine.AI.NavMeshAgent' does not contain a definition for `isStopped' and no extension method `isStopped' of type `UnityEngine.AI.NavMeshAgent' could be found. Are you missing an assembly reference?
Assets/PlayMaker PathFinding/Agent/SetAgentIsStopped.cs(58,11): error CS1061: Type `UnityEngine.AI.NavMeshAgent' does not contain a definition for `isStopped' and no extension method `isStopped' of type `UnityEngine.AI.NavMeshAgent' could be found. Are you missing an assembly reference?



Here is the tutorial I am following if needed: https://www.youtube.com/watch?v=bOOgfjJlkgI
« Last Edit: September 15, 2017, 01:19:46 AM by jeanfabre »

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 2305
    • View Profile
    • jinxtergames
Re: PathFinding Addon Issue
« Reply #1 on: September 12, 2017, 07:19:41 AM »
Hi,
i tried on unity 5.6.2 there they seem to work
Did you use the ecosystem to get them?

bazzaro135

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: PathFinding Addon Issue
« Reply #2 on: September 12, 2017, 07:47:44 AM »
Yes I did, I can try upgrading my unity and see if that works.

bazzaro135

  • Playmaker Newbie
  • *
  • Posts: 3
    • View Profile
Re: PathFinding Addon Issue
« Reply #3 on: September 12, 2017, 09:18:07 AM »
I updated my unity to 5.6.2 and it seems to be working now. Thank you for the help.