playMaker

Author Topic: vuforia package error[SOLVED]  (Read 550 times)

Ofonna

  • Full Member
  • ***
  • Posts: 230
    • View Profile
vuforia package error[SOLVED]
« on: October 13, 2017, 05:11:36 PM »
heyy guys,

i just downloaded the vuforia package from the ecosystem and this errors popped up.
please help
« Last Edit: November 28, 2017, 11:10:22 PM by jeanfabre »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12833
  • Official Playmaker Support
    • View Profile
Re: vuforia package error
« Reply #1 on: October 25, 2017, 11:30:18 PM »
Hi,

 Yep, looks like I need to give it a pass with the latest version of vuforia.

 Please bump me early next week if I haven't provided a new package.

 Bye,

 Jean

Ofonna

  • Full Member
  • ***
  • Posts: 230
    • View Profile
Re: vuforia package error
« Reply #2 on: October 26, 2017, 12:13:27 AM »
ok, thank you Jean!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12833
  • Official Playmaker Support
    • View Profile
Re: vuforia package error
« Reply #3 on: October 26, 2017, 11:50:52 PM »
Hi,

 what version of Unity do you have?

Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12833
  • Official Playmaker Support
    • View Profile
Re: vuforia package error
« Reply #4 on: October 27, 2017, 12:55:26 AM »
Hi,

 I think you simply did not import vuforia properly, unfortunatly, vuforia packaging is careless and they don't pauy attention for backward compatibility, so

1:create a fresh project,
2:import vuforia,
3: import PlayMaker
4: import the vuforia package from ecosystem

 If that works, then you'll need to clean up your existing project from the old vuforia stuff... pain.

 I updated the github repository using the latest 6.2 and it was fine ( not 2017.2 as it's now shipped with Unity).

Bye,

 Jean

Ofonna

  • Full Member
  • ***
  • Posts: 230
    • View Profile
Re: vuforia package error
« Reply #5 on: October 27, 2017, 12:58:50 AM »
hi, thanks Jean, i'm currently using unity 2017.2 so i guess i should be fine then,

thanks!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12833
  • Official Playmaker Support
    • View Profile
Re: vuforia package error
« Reply #6 on: October 27, 2017, 01:12:11 AM »
Hi,

 ok, then, this is a completly different deal. I am still downloading 2017.2 with vuforia module, so I can't say right now if it works or not. I'll test asap.

Bye,

 Jean

jamdalu

  • Playmaker Newbie
  • *
  • Posts: 9
    • View Profile
Re: vuforia package error
« Reply #7 on: November 14, 2017, 01:36:21 PM »
Hi Jean -I am getting this error in Unity 2017.2:

Assets/PlayMaker Vuforia/Scripts/PlayMakerVuforiaVirtualButtonProxy.cs(68,32): error CS0246: The type or namespace name `VirtualButtonAbstractBehaviour' could not be found. Are you missing an assembly reference?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12833
  • Official Playmaker Support
    • View Profile
Re: vuforia package error
« Reply #8 on: November 22, 2017, 12:40:57 AM »
Hi,

 Vuforia implementation changed in 2017, I need to create a dedicated package for this now. the current package will only be for Unity 5 and less. Will upload this week.

 Bye,

 Jean

Basti81

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Re: vuforia package error
« Reply #9 on: November 22, 2017, 06:44:40 AM »
Hi,

 Vuforia implementation changed in 2017, I need to create a dedicated package for this now. the current package will only be for Unity 5 and less. Will upload this week.

 Bye,

 Jean

Sounds great!

We have also big problems with the playmaker Vuforia Package for Unity 2017.2.

Thanks!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12833
  • Official Playmaker Support
    • View Profile
Re: vuforia package error
« Reply #10 on: November 27, 2017, 12:56:42 AM »
Hi,

 It's up on the Ecosystem. Make sure you get the Unity 2017 version (Check the tag)

more infos here

 Bye,

 Jean

Basti81

  • Playmaker Newbie
  • *
  • Posts: 2
    • View Profile
Re: vuforia package error
« Reply #11 on: November 27, 2017, 01:09:17 AM »
Hi,

 It's up on the Ecosystem. Make sure you get the Unity 2017 version (Check the tag)

more infos here

 Bye,

 Jean

Thanks a lot Jean!