playMaker

Author Topic: Photon Not working on build[SOLVED]  (Read 522 times)

Ofonna

  • Full Member
  • ***
  • Posts: 230
    • View Profile
Photon Not working on build[SOLVED]
« on: November 20, 2017, 09:28:42 PM »
hi, my photon project works perfectly in the editor but when i build the project it does't respond, on joined or created room, i'm mean to load scene but nothing works, please what could possible be the issue here?

even the demo scene doesn't respond when i click create

thanks
« Last Edit: November 21, 2017, 11:21:06 PM by jeanfabre »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13857
  • Official Playmaker Support
    • View Profile
Re: Photon Not working on build
« Reply #1 on: November 21, 2017, 03:44:59 AM »
Hi,

 create a new project, import just photon, test the demos, do they work?

Bye,

 Jean

Ofonna

  • Full Member
  • ***
  • Posts: 230
    • View Profile
Re: Photon Not working on build
« Reply #2 on: November 21, 2017, 08:34:07 AM »
i just did and it no longer works in the editor,

this is the error i keep getting

CreateRoom failed. Client is not on Master Server or not yet ready to call operations. Wait for callback: OnJoinedLobby or OnConnectedToMaster.
« Last Edit: November 21, 2017, 08:58:44 AM by Carmichael »

Ofonna

  • Full Member
  • ***
  • Posts: 230
    • View Profile
Re: Photon Not working on build
« Reply #3 on: November 21, 2017, 09:02:33 AM »
hi jean, i just noticed some more errors and apperently some scripts are missing from the "Game" gameobject in the demo scene, but i dont know what scripts,

Ofonna

  • Full Member
  • ***
  • Posts: 230
    • View Profile
Re: Photon Not working on build
« Reply #4 on: November 21, 2017, 02:34:21 PM »
i changed my region setting from cloud to best region and it worked!