playMaker

Author Topic: GetProperty can't get the int value (no int store value displays) [SOLVED]  (Read 1448 times)

bendaowei

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
There is no store value for GetProperty when int type selected.
Please look into the attachment and set the object as EZGUI, UIPanel, int type.

Could you tell how to fix this bug or when will next version of playmaker be published with this bug fixed?
« Last Edit: March 27, 2012, 06:54:23 PM by bendaowei »

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3627
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: GetProperty can't get the int value (no int store value displays)
« Reply #1 on: March 26, 2012, 11:07:04 PM »
I just tested here and int properties seem to work fine... Are you sure the property you're targeting is an int type? I don't have EZGUI to test with...

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14316
  • Official Playmaker Support
    • View Profile
Re: GetProperty can't get the int value (no int store value displays)
« Reply #2 on: March 27, 2012, 01:01:04 AM »
Hi,

 I tested here ( tho without your asset, I am not sure how to load a .asset file, how did you get that asset?, make a package instead, tho for license reason, you are not allowed to distribute EZGUi scripts... so)


 I have created a Fsm Object variable, set it to type "UIPanel", then select an GameObject with a UiPanel
and there is only one property "index" as int. And it seems to work.

 So, what property of the uiPanel are you exactly looking for?

 Maybe you are missing a procedure, for example, using get property action on a gameObject will nto show the various component s( tho it could be nice Alex :) ) so you have to make a FsmObject variable first and set it up to the object type you want, then you'll have access to all these properties to store values from.

 Bye,

 Jean

bendaowei

  • Playmaker Newbie
  • *
  • Posts: 4
    • View Profile
Re: GetProperty can't get the int value (no int store value displays)
« Reply #3 on: March 27, 2012, 06:51:48 PM »
The component variable should set the default object value. fixed, thanks.