playMaker

Author Topic: PlayerSettings Validation  (Read 1972 times)

PET

  • Full Member
  • ***
  • Posts: 137
    • View Profile
    • GamerPET
PlayerSettings Validation
« on: April 12, 2017, 12:07:56 AM »
Hello guys,

I just updated my project to Unity 5.6 and I updated Playmaker to 1.8.3. Now I get this when I hit Play:

Quote
PlayerSettings Validation: Requested build target group (27) doesn't exist; #define symbols for scripting won't be added.
UnityEditor.PlayerSettings:SetScriptingDefineSymbolsForGroup(BuildTargetGroup, String)
HutongGames.PlayMakerEditor.PlayMakerDefines:AddScriptingDefineSymbolToAllTargets(String) (at Assets/PlayMaker/Editor/PlayMakerDefines.cs:42)
HutongGames.PlayMakerEditor.PlayMakerDefines:.cctor() (at Assets/PlayMaker/Editor/PlayMakerDefines.cs:21)
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes()

Any idea how to get rid of this?
Technical Game Designer
www.GamerPET.com

elusiven

  • Full Member
  • ***
  • Posts: 233
  • Debt we all must pay...
    • View Profile
Re: PlayerSettings Validation
« Reply #1 on: April 12, 2017, 07:12:28 AM »
Have you added the right symbols in the build settings?

"Scripting Define Symbols" 

Sounds like an issue with that

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15060
  • Official Playmaker Support
    • View Profile
Re: PlayerSettings Validation
« Reply #2 on: April 12, 2017, 11:40:47 PM »
Hi,

 What platform are you targeting exactly?

 Bye,

 Jean

PET

  • Full Member
  • ***
  • Posts: 137
    • View Profile
    • GamerPET
Re: PlayerSettings Validation
« Reply #3 on: April 13, 2017, 01:35:17 AM »
I noticed those errors in some Android projects.
Technical Game Designer
www.GamerPET.com

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15060
  • Official Playmaker Support
    • View Profile
Re: PlayerSettings Validation
« Reply #4 on: April 17, 2017, 11:51:22 PM »
Hi,

 in "some": that would mean then that PlayMaker would either not be properly installed in these projects exposing the issue, can you double check?

Bye,

 Jean

PET

  • Full Member
  • ***
  • Posts: 137
    • View Profile
    • GamerPET
Re: PlayerSettings Validation
« Reply #5 on: April 18, 2017, 01:48:55 AM »
Well the proejct was fine on 5.5.3. I updated to 5.6 and I get this:

« Last Edit: April 20, 2017, 01:17:12 AM by PET »
Technical Game Designer
www.GamerPET.com

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 15060
  • Official Playmaker Support
    • View Profile
Re: PlayerSettings Validation
« Reply #6 on: April 19, 2017, 12:10:40 AM »
Hi,

 you need to update PlayMaker to 1.8.4

http://hutonggames.com/playmakerforum/index.php?topic=14968.msg69264#msg69264

Bye,

 Jean