playMaker

Author Topic: Animator State Sync in Sub-state machine doesn't work [SOLVED]  (Read 173 times)

Sujetoso

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Animator State Sync in Sub-state machine doesn't work [SOLVED]
« on: December 28, 2018, 01:49:19 PM »
Hello! I'm using the PlayMaker Animator State Synchronization from the ecosystem, is working great even in a sub-state machine but if I use one sub-state machine inside another it doesn't work anymore, which is really important because that's the way I'm organizing all my character attack actions.

Hope you can help me to fix this issue Thanks!!

Image attach for reference.
« Last Edit: January 14, 2019, 12:20:23 AM by jeanfabre »

Sujetoso

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #1 on: January 04, 2019, 09:32:48 AM »
Still can't figure it out ):

djaydino

  • Administrator
  • Hero Member
  • *****
  • Posts: 3730
    • View Profile
    • jinxtergames
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #2 on: January 05, 2019, 02:32:33 AM »
Hi.
I will ping jean (hes the creator of the PlayMaker Animator State Synchronization) to have a look, but he will probably not reply before Monday.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13732
  • Official Playmaker Support
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #3 on: January 08, 2019, 12:13:46 AM »
Hi,

 Ok, could you send me an Animator Setup so that I can see what can be done?

Bye,

 Jean

Sujetoso

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #4 on: January 08, 2019, 08:22:00 PM »
Thanks djaydino and jeanfabre!

Here is a zip with a prefab and the animator I used as an example, it doesn't contain any playmaker scripts, again thanks a lot!

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13732
  • Official Playmaker Support
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #5 on: January 09, 2019, 10:31:37 PM »
Hi,

 Cool, thanks, I'll have a play with this and work it out.

 Bye,

 Jean

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13732
  • Official Playmaker Support
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #6 on: January 10, 2019, 03:23:48 AM »
Hi,

 Ok, found the issue, it's an old script and so it was only accounting for Unity 4 or 5, and since then 2017, 2018 came so this script thinks it's Unity 4...

Can you try with the script attached ( replace it in your assets)

 If it works on your end, I'll push an update.

Bye,

Jean

 Jean

Sujetoso

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #7 on: January 11, 2019, 04:04:15 PM »
I will give it a try in a couple of hours, thanks a lot Jean!

Sujetoso

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work
« Reply #8 on: January 11, 2019, 06:02:49 PM »
I just tested it and it works great! Thank you so much Jean! ;D

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 13732
  • Official Playmaker Support
    • View Profile
Re: Animator State Sync in Sub-state machine doesn't work [SOLVED]
« Reply #9 on: January 14, 2019, 12:20:36 AM »
Cool :)

Bye,

 Jean