playMaker

Author Topic: [SOLVED] New iTween Actions not working  (Read 2308 times)

mindfarm

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
[SOLVED] New iTween Actions not working
« on: June 28, 2013, 12:23:40 PM »
Hi,

few days ago I noticed that I can't get any new iTween actions to work while everything i added some time ago still works fine. Similar problem like the one in that topic: http://hutonggames.com/playmakerforum/index.php?topic=3978.0

The last two days I've been trying to fix this (re-importing Playmaker, iTween double-checking other actions a.s.o) without success. No warnings or errors, it just stands still...

Any help would be appreciated. Thanks.
« Last Edit: July 26, 2013, 07:22:36 AM by mindfarm »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14692
  • Official Playmaker Support
    • View Profile
Re: New iTween Actions not working
« Reply #1 on: July 01, 2013, 12:19:57 AM »
Hi,

 if it stand stills, what happeneds when you start using playmaker and itween actions?

bye,

Jean

mindfarm

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: New iTween Actions not working
« Reply #2 on: July 01, 2013, 12:53:38 PM »
Those I added a couple of weeks ago move and rotate fine, the recently added ones don't (do anything). In the FSM-View the state is active, but of course the coordinates are not changing. As is wrote, no errors or information. No weird "other assets" installed recently, nothing. Quite elusive. Rolling back to some older backups ended at the same point. A little frustrating after months of work but I'm afraid a lot of us know that.

Looks like I have to live with skipping some stuff I planned, using moveToward etc. but not even knowing what caused and how to avoid this.. hmm. Different :/ When I posted this I was just hoping for something "hey did you also try that?" like the other guy.. :/

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14692
  • Official Playmaker Support
    • View Profile
Re: New iTween Actions not working
« Reply #3 on: July 01, 2013, 11:48:53 PM »
Hi,

 moveTowards works fine, it's likely you are within a logic issue, or something you did that you do not expect to have an impact of that feature. If you can send me a project, I'll have a look.

bye,

 Jean

mindfarm

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: New iTween Actions not working
« Reply #4 on: July 02, 2013, 12:48:42 AM »
Hi,

yes I think so since it doesn't happen in a new project. Which doesn't help much without knowing exactly WHAT went wrong. Thanks for your offer Jeanfabre, but my project folder is about 3.5 gb (1.7 gb as .7z) at the moment. Guess that's a bit huge and maybe not worth the effort..?

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14692
  • Official Playmaker Support
    • View Profile
Re: New iTween Actions not working
« Reply #5 on: July 02, 2013, 02:32:12 AM »
Hi,

 Size doesn't matter, send it if you want me to have look, I am fine with this. else I am not sure how I can help you without a repro.

bye,

 Jean

mindfarm

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: New iTween Actions not working
« Reply #6 on: July 02, 2013, 11:29:26 AM »
Ok.. uploading to Dropbox. *yawn* I'll pm you then. Thanks!! :)

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14692
  • Official Playmaker Support
    • View Profile
Re: New iTween Actions not working
« Reply #7 on: July 11, 2013, 04:14:04 AM »
Hi,

 Sorry, lost track of this, did I looked at it?  :P can't remember.

bye,

 Jean

mindfarm

  • Playmaker Newbie
  • *
  • Posts: 7
    • View Profile
Re: New iTween Actions not working
« Reply #8 on: July 26, 2013, 07:22:11 AM »
Deleted my last post, since the problem is finally solved.
As expected my bad and fortunately way more simple than I thought.

Randomly found it and it sounds as ridiculous as it is..
For some reasons the Fixed Timestep / Scale settings were messed up and set to very strange values. So if anyone else is having this problem.. take a look.

Thanks again Jeanfabre!