playMaker

Author Topic: Playmaker FSM Editor window slowing down startup time  (Read 2410 times)

NKoufou

  • Playmaker Newbie
  • *
  • Posts: 6
    • View Profile
Playmaker FSM Editor window slowing down startup time
« on: November 09, 2011, 12:15:39 PM »
Hey,

Has anyone noticed that when the playMaker FSM editor window is open it adds a few seconds delay when pressing play in the editor? I noticed this on both Win and Mac versions of Unity.
Startup time is usually around 3-4 seconds, when the FSM window is open there is a delay of 10-15 seconds. I am currently on version 1.2.1 and my scene has about 6-7 FSMs. The project itself is quite big though, over 2GB and 19000 files.

Any suggestions?
Nick

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14501
  • Official Playmaker Support
    • View Profile
Re: Playmaker FSM Editor window slowing down startup time
« Reply #1 on: November 09, 2011, 10:06:01 PM »
Hi,

 Yes, I have the same problem on large projects too, but I would not say it's as much as 15 secs tho, usually I get a real hog when I edit custom actions, that takes more time ( the playmaker editor being greyed out).

 Do you have lots of fsm or is the project simple big in texture and content? Are you using lots of prefabs?


 Bye,

 Jean

NKoufou

  • Playmaker Newbie
  • *
  • Posts: 6
    • View Profile
Re: Playmaker FSM Editor window slowing down startup time
« Reply #2 on: November 10, 2011, 07:42:55 PM »
I have 6-7 FSMs, over 1500 prefabs, over 2000 textures, you get the idea....

I assume that playMaker is scanning the project folder? Any ideas for what reason and if I can somehow restrict the folders it's monitoring?

Thanks
Nick

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3632
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Re: Playmaker FSM Editor window slowing down startup time
« Reply #3 on: November 10, 2011, 08:37:21 PM »
Try turning off Auto-Load Prefabs in preferences.

I'll poke around to see what else might be causing this...

NKoufou

  • Playmaker Newbie
  • *
  • Posts: 6
    • View Profile
Re: Playmaker FSM Editor window slowing down startup time
« Reply #4 on: November 14, 2011, 11:18:41 AM »
This worked! (turned off both Auto-Load all prefabs in project and in scene). Thanks, I guess we have too many prefabs?

How exactly do these options work? What's the side effect of turning these off?