playMaker

Author Topic: Problems building with Unity Free Version  (Read 3851 times)

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3207
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Problems building with Unity Free Version
« on: August 28, 2013, 12:17:28 PM »
Playmaker ships with Photon Networking. Photon currently requires Unity Pro for iOS and Android. If you have the free version of Unity please delete the Photon Unity Networking folder.
« Last Edit: September 04, 2013, 07:11:44 PM by Alex Chouls »

escpodgames

  • Hero Member
  • *****
  • Posts: 673
    • View Profile
    • Assets
Re: Photon requires iOS Pro
« Reply #1 on: August 28, 2013, 04:01:32 PM »
Photon will soon be available to free users (based on their last newsletter)

Lane

  • Administrator
  • Hero Member
  • *****
  • Posts: 2484
  • Yup.
    • View Profile
    • Cleverous
Re: Photon requires iOS Pro
« Reply #2 on: August 28, 2013, 04:37:13 PM »
SURPRISE!

Khoa1994

  • Playmaker Newbie
  • *
  • Posts: 33
    • View Profile
Re: Problems building with Unity Free Version
« Reply #3 on: August 03, 2014, 08:29:52 AM »
After deleting the "Photon Unity Networking" folder, I still get the error "Error building Player: SystemException: System.Net.Sockets are supported only on Unity iOS Pro. Referenced from assembly 'Assembly-CSharp'." when I build my game for iOS. Please help me fix this.

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 12351
  • Official Playmaker Support
    • View Profile
Re: Problems building with Unity Free Version
« Reply #4 on: September 22, 2014, 10:09:59 PM »
Hi,

 it's likely that you haven't cleaned up your project. Maybe you are using another framework from the asset store that use sockets.

 typically: create a fresh project, import PlayMaker, delete the "Photon Unity networking" folder and build, what happen then?

 Bye,

 Jean