playMaker

Author Topic: Animations not playing  (Read 1552 times)

Moza

  • Playmaker Newbie
  • *
  • Posts: 8
    • View Profile
Animations not playing
« on: March 25, 2014, 08:43:48 PM »
Hi all,

I am very new to Playmaker and seem to be having a problem getting any animations to work when not using the animator component. I'm obviously missing a very basic or vital step but I just set up a couple basic animations 'run' and 'jump' and want to use the Play Animation Action to play them accordingly. The game is just a simple 2D game using the new 2D Unity features.

So basically my Player has the Animation Component with run and jump animations. Run is the default, Play Automatically is also ticked and it still doesnt work. Same for when I use the Play Animation Action.

Any help will be appreciated. Thanks and also well done on an amazing product like Playmaker.


bradford6

  • Playmaker Newbie
  • *
  • Posts: 1
    • View Profile
Re: Animations not playing
« Reply #1 on: April 02, 2014, 06:37:03 PM »
Hi,
I am new to Playmaker as well. (actually bought it years ago but never had time to actually dig in)

I'll list out a few possibilities
1. does the GameObject have an 'animation' component in the inspector
2. in the FSM, do you have an initialization state that    has the 'Add Animation Clip' action?

psypol

  • Playmaker Newbie
  • *
  • Posts: 39
    • View Profile
Re: Animations not playing
« Reply #2 on: May 06, 2014, 01:16:49 PM »
hello. i have the same problem.

when i put an ANIMATOR on a character it plays the animation defined as Default
in the "Animator" component, under the schematics you can open by double clicking in "Controller" Field

But i'm not able to interfere in ANY way with the animations
i tried different ways :
- just with "Animation" component and using "Play Animation" action
- also tried with "Animator Play" specifying a state i want to jump on (from PlayMakerAnimatorActions package)
- then i tried to also add "PlayMakerAnimatorMoveProxy" thinking it will help ..

nothing works .. the only way i can decide to play a given animation is by tweaking the already provided schematic.

N.B : im totally a noob in the field of animator in Unity
N.B2 : i'm using unity 4.3.4
N.B3 : im using playmaker 1.7.6


thanks for your help

« Last Edit: May 06, 2014, 01:20:06 PM by psypol »

jeanfabre

  • Administrator
  • Hero Member
  • *****
  • Posts: 14684
  • Official Playmaker Support
    • View Profile
Re: Animations not playing
« Reply #3 on: May 07, 2014, 05:53:33 AM »
Hi,

 You'll first need to study examples to understand how to setup animator and then control it using PlayMaker.

 Have you studied or actually know about the animator support for PlayMaker?

https://hutonggames.fogbugz.com/?W1031

bye,

 Jean