playMaker

Author Topic: Asset Store Bug!  (Read 338 times)

Alex Chouls

  • Administrator
  • Hero Member
  • *****
  • Posts: 3477
  • Official Playmaker Support
    • View Profile
    • LinkedIn
Asset Store Bug!
« on: February 05, 2019, 12:08:03 PM »
If you have errors with a fresh install from the Asset Store you may be running into this Asset Store bug:

The Unity Asset Store does not properly keep track of which version an asset was downloaded for. For example, if you run Unity 2018.3 and download Playmaker you get the version for 2018.3. If you now open Unity 2017.4 and import Playmaker, the Asset Store will try to import the 2018.3 version and you will get errors!

To fix this, you have to manually re-download PlayMaker when you switch Unity versions. The new Asset Store UI does not make this easy, but you can switch to Shop on Old Store in the Asset Store settings. Then go to the Download Manager, find Playmaker and manually download it again.

Alternatively, you can delete the Asset Store cache (find Hutong Games LLC to just delete Playmaker):
https://answers.unity.com/questions/690729/how-do-you-remove-packages-already-downloaded-from.html

Sorry for the inconvenience! We reported this bug to Unity quite some time ago, and they were able to reproduce it, but we're still waiting on a fix...

« Last Edit: February 05, 2019, 12:10:48 PM by Alex Chouls »